Remote Host pada IP dinamik


studi kasus pada kawan - kawan yang mendapat IP Public yang berubah-ubah (dynamic) dari ISP. dan ingin meremote server dibawah IP tersebut. alhasil pasti kerepotan harus merubah satu persatu IP port forwading yang telah dibuat pada /ip firewall nat. (bayangkan kalo banyak yang sudah dibuat) heehee

sebagai salah satu contoh port forwading yang dibuat seperti ini :

/ip firewall nat \
add action=dst-nat chain=dstnat comment="Dinamic Port Forwarding" disabled=no dst-address=\
ip_public dst-port=3306 protocol=tcp to-addresses=ip_server \
to-ports=3306

dikarenakan ip public yang didapat dari ISP adalah dinamik maka mau gak mau kita merubah ip publik di nat tersebut secara manual. nah karena itu sangat merepotkan, kita coba dengan cara merubahnya secara otomatis dengan menggunakan scripting. ini scripting yang kita gunakan :

:local newip
:local iplen

/ip address
:set iplen [:len [get [find interface=interface_public] address]]
:set newip [:pick [get [find interface=interface_public] address] 0 ($iplen-3)]

/ip firewall nat
set [find comment="Dinamic Port Forwarding"] dst-address=$newip

scipt diatas fungsinya yaitu cek ip pada interface public (WAN) dan apabila berubah maka Nat yang komentar "dinamic port forwading"  akan dirubah otomatis pada bagian dst-address nya.


Remote Host pada IP dinamik Remote Host pada IP dinamik Reviewed by cangkal on 12.00 Rating: 5

1 komentar:

  1. mantabs infonya gan, ayo update trs infonya gan tentang IT yg terbaru
    7 Passenger Vehicles | 7 passenger SUV | http://www.7passengervehiclesworld.com

    BalasHapus

penulis senang dengan adanya pembaca yang meninggalkan jejak. :)

Diberdayakan oleh Blogger.